تعریف یک DNS redirect در روتر میکروتیک

0 589
Telegram_GEEKBOY

گاهی در شبکه می خواهیم که کاربران وقتی که از DNS به صورت دستی بر روی کارت شبکه استفاده می کنند به همان DNS هایی که شما می خواهید Redirect بشوند و در واقع تغییر در DNS کارت شبکه کلاینت ها مشکلی در اتصال به اینترنت و باز شدن صفحات وب ایجاد نکند و ما بتوانیم درخواست های DNS را کش کنیم برای اینکار میتوانید به ادامه مطلب مراجعه نمایید.

گیک بوی بر روی سرورهای قدرتمند هاست هی میزبانی می شود

1- وارد firewall > Nat شده و یک رول از نوع dstnat تعریف می کنیم:

2- در قسمت protocol یک بار با TCP و یک بار هم با UDP این رول را می نویسیم.

3- در قسمت dst-port عدد 53 را وارد کنید (Port DNS)

4- در تب action نیز یک dst-nat می نویسیم که در قسمت to addresses باید آدرس DNS Server خودمان را وارد کنیم و در قسمت to-ports نیز باید دوباره عدد 53 را وارد کنیم.

1

2

3

در صورت نیاز می توانید با تغییر آی پی DNS Server دستورات زیر آن را از طریق ترمینال Winbox وارد میکروتیک کنید.

اول دستور زیر را وارد کرده:

/ip firewall nat

و سپس دستورات زیر را وارد کنید:

add chain=dstnat action=dst-nat to-addresses=192.168.88.1 to-ports=53 protocol=tcp dst-port=53

add chain=dstnat action=dst-nat to-addresses=192.168.88.1 to-ports=53 protocol=udp dst-port=53

در صورتی که مطالب سایت برای شما مفید بوده است، می توانید از طریق لینک زیر از سایت حمایت کنید.

image_pdfدانلود نسخه PDF

ارسال یک نظر

آدرس ایمیل شما منتشر نخواهد شد.