سایتی برای آموزش شبکه در زمینه های سیسکو میکروتیک مایکروسافت مجازی سازی و دیگر مباحث شبکه

آموزش های کوتاه ولی کاربردی میکروتیک قسمت دوم

3 507
Telegram_GEEKBOY
آموزش های کوتاه ولی کاربردی میکروتیک قسمت اول
آموزش های کوتاه ولی کاربردی میکروتیک قسمت دوم

گیک بوی بر روی سرورهای قدرتمند هاست هی میزبانی می شود

در ادامه مطلب قبلی (قسمت اول) اینبار هم آموزش های کوتاه ولی کاربردی میکروتیک را در ادامه مطلب قرار داده ایم.

هدایت کاربران متصل به آدرس مورد نظر (Redirect to address)

هنگامی که شما میخواهید تعیین کنید کاربران متصل یه میکروتیک از حالت استفاده معمولی از اینترنت خارج شده و هر آدرسی را که در مورورگر خود وارد میکنند به آدرسی که شما میخواهید بروند (این روش را برای Credit Finished استفاده میکنند) از دستورات زیر استفاده میکنیم.

در حلقه dstnat در قسمت firewall > NAT از دستورات زیر استفاده مینماییم:

chain=dstnat src address=192.168.1.0/24 protocol=tcp action=dst-nat=185.125.2.24

chain=srcnat action=masquerade

راه اندازی OVPN در میکروتیک

OVPN یکی از راه های امن برای اتصال نقطه به نقطه در روتر های میکروتیک میباشد.

ما قصد داریم نحوه راه اندازی صحیح و امن این نوع اتصال را به شما آموزش دهیم.

ابتدا دو عدد فایل (ca.key و  ca.crt) پیوست شده در همین مطلب را در میکروتیک خود آپلود نمایید. (فایل ها را از حالت Zip خارج کنید)

لینک دانلود

سپس از قسمت System > Certificate هر 2 فایل را بدون Passpharse ایمپورت نمایید.

و از قسمت PPP > OVPN server تیک Enable را قرار داده و Certificate را انتخاب و OK کنید.

کار به اتمام رسیده و اتصال بین 2 سرور را از طریق کانکشن ovpn میتوانید برقرار نمایید و Gateway route سرور خود را بر اساس اتصال امن تعیین نمایید.

ارتباط میکروتیک و لینوکس با IP Tunnel

برای اتصال میکروتیک و لینوکس Centos از طریق IPIP TUNNEL به یکدیگر از روشی که در زیر قرار داده ایم می توانید استفاده کنید.

ابتدا با نرم افزار Putty به سرور لینوکس خود وصل شوید و دستورات زیر رو که در ادامه همین مطلب قرار گرفته وارد کنید.

nano /etc/sysconfig/network-scripts/ifcfg-ipip

برای اینکار کافیه درون Putty کلیک راست کنید.

DEVICE=ipip
BOOTPROTO=none
ONBOOT=no
TYPE=IPIP
PEER_OUTER_IPADDR=Mikrotik IP Address
PEER_INNER_IPADDR=10.20.40.2
MY_INNER_IPADDR=10.20.40.1

سپس Crtl+x

nano /etc/rc.d/rc.local

ifup ipip
ifconfig ipip

سپس Crtl+x

Shutdown -r now

اسکریپت تنظیم پهنای باند برای یک رنج IP

برای تنظیم Queues برای یک رنج IP Address بخصوص بصورت یکباره از اسکریپتی که براتون در ادامه مطالب قرار دادم میتونید استفاده کنید .

/queue simple
:for i from=1 to=254 do={
add name=(“E.$i”) target-addresses=(“30.30.30.$i”) \
dst-address=0.0.0.0/0 interface=all limit-at=0/0 max-limit=512000/512000 disabled=no
}

به جای 30.30.30 باید net id خودتون رو قرار بدید و RUN Script رو کلیک کنید.

جدا کردن دانلود و آپلود روی میکروتیک

برای جدا نمودن rate upload and download از 2 پورت متمایز به روش زیر عمل میکنیم.

ip firewall mangle
add action=mark-packet chain=prerouting in-interface=ether1 new-packet-mark=upload
add action=mark-packet chain=postrouting out-interface=ether2 new-packet-mark=download

سپس NAT تعریف میکنیم

ip firewall NAT
add action=masquerade chain=srcnat packet-mark=upload
add action=masquerade chain=srcnat packet-mark=download

در صورتی که مطالب سایت برای شما مفید بوده است، می توانید از طریق لینک زیر از سایت حمایت کنید.

image_pdfدانلود نسخه PDF
3 نظرات
  1. […] ادامه مطلب قبلی (قسمت اول – قسمت دوم) اینبار هم آموزش های کوتاه ولی کاربردی میکروتیک را در […]

  2. […] ادامه مطلب قبلی (قسمت اول – قسمت دوم – قسمت سوم) این بار هم آموزش های کوتاه ولی کاربردی […]

  3. […] ادامه مطلب قبلی (قسمت اول – قسمت دوم) اینبار هم آموزش های کوتاه ولی کاربردی میکروتیک را در […]

ارسال یک نظر

آدرس ایمیل شما منتشر نخواهد شد.