آموزش راه اندازی روتر سیسکو به زبان ساده

0 775
Telegram_GEEKBOY

کانفیگ روتر سیسکو به شکل ابتدایی و آسان کاری سختی نیست در واقع نیاز نیست که شما یک network expert باشید تنها لازم است با مفاهیم شبکه آشنا بوده و کمی گیک باشید!

گیک بوی بر روی سرورهای قدرتمند هاست هی میزبانی می شود

روتر های سیسکو دستگاه های دوست داشتنی هستند آنها خراب نمیشوند (به همین راحتی) نه نمیگویند (از پس همه نیاز های شما بر می آیند) قوی هستند هنگ نمیکنند با توجه به ماموریت پیچیده شان؛ خیلی پیچیده نیستند سخت کوشند.

روتر های سیسکو بنا به نیاز و ماموریت کاری، مدل های مختلفی دارند از ابعاد دسکتاپ مثل سری 1600 – 1700 – 1800 – 1900 و .. تا هم اندازه یک یخچال مثل 7613 ولی همه شان کارشان یکی ایست: ”مدیریت ترافیک شبکه” که این امر میتوانید مسیریابی باشد مثل روتر های اولیه یا حتی یک کنفرانس ویدیویی و یا یک تماس تلفنی، که البته روتر در شکل سنتی و دیرینه وظیفه اش مسیریابی ترافیک شبکه بوده ولی با پیشرفت و توسعه نیاز ها روتر ها به سمت multi layer و service integration پیش رفتند بدین سان که قبلا یک مسیریاب فقط یه دیوایس لایه 3 محسوب میشد ولی حال در چندین لایه کار میکند.

کانفیگ روتر سیسکو:

خب در ابتدا روتر را با کابل کنسول مخصوص سیسکو به یک PC متصل کنید و از طریق یک نرم افزار ترمینال مثل Putty به کنسول روتر سیسکو متصل شوید حال فارغ از ارتباطات شبکه ای و کانفیگ روتر میتوانید به کارتان برسید.

قدم اول: در ابتدا ما به تنظیمات مربوط به ورود و اهراز هویت و همچنین یک نام برای روتر سیسکو میپردازیم:

user-mode

Router> enable ( ورود به محیط پریویلیج )
Router# configure terminal ( ورود به محیط کانفیگ )
Router(config)#
Router(config)# hostname Router ( اختصاص یک هسات نیم )
Router(config)# aaa new-model ( فعال کردن aaa )
Router(config)# username GEEKBOY password 0 GEEKBOY
Router(config)# enable secret GEEKBOY ( رمز عبور مربوط به محیط پریویلیج )
Router(config)# no ip domain-lookup
Router(config)#

قدم دوم: تنظیمات مربوط به اینترفیس های اترنت و اختصاص IP به هر کدام:

IP-config

interface

Router(config)# interface fastethernet 0 ( ورود به تنظیمات اینترفیس مورد نظر )
Router(config-int)#
Router(config-int)# ip address 192.1.1.2 255.255.255.0 ( اختصاص IP )
Router(config-int)# no shutdown ( فعال کردن اینترفیس )
Router(config-int)#

قدم سوم: نوشتن Static Route (امیدوارم با این مفهوم آشنا باشید):

static-route

صورت دستود:

ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]}

Router(config)# ip route 0.0.0.0 0.0.0.0 192.168.1.1

(یعنی همه ترافیک را بفرست به 192.168.1.1 )

Router(config)# ip route 10.10.10.0 255.255.255.0 192.168.1.3

( بدین معنی که برای دسترسی به شبکه 10.10.10.0/24 ترافیک را به سمت 192.168.1.3 بفرست )

قدم چهارم: نوشتن Static Nat برای اشتراک اینترنت توسط روتر سیسکو:

پیاده سازی Static NAT شاید یکی از پر کاربرد ترین و ساده ترین سناریو های مورد استفاده باشد. با توجه به محدودیت میزان منابع IP در بعضی موارد ما ملزم به استفاده از Network Address Translation و یا همان NAT هستیم. بدین ترتیب که درخواست های ارسالی از شبکه داخلی با IP های خصوصی و نامعتبر را به یک یا چند Valid IP اختصاص میدهیم. برای مثال ما یک شبکه با 100 کلاینت و یک عدد Valid IP جهت دسترسی به اینترنت در اختیار داریم.

  • interface FastEthernet0/0
  • description NET
  • ip address 217.218.1.1 255.255.255.252
  • ip nat outside
  • ip virtual-reassembly in
  • end

و اینترفیس شبکه داخلی:

  • interface FastEthernet0/1
  • description Local Network
  • ip address 192.168.1.1 255.255.255.0
  • ip nat inside
  • ip virtual-reassembly in
  • end

نیاز ما ایجاد دسترسی به اینترنت برای رنج 192.168.1.0/24 است:

Core-Router#conf t

Core-Router(config)#ip acce s nat

Core-Router(config-std-nacl)#per 192.168.1.1 0.0.0.255 رنج آدرس های مجاز برای دسترسی به نت

Core-Router(config)#ip nat inside source list nat interface FastEthernet0/0 overload

  • Core-Router(config)#int fas 0/1 اینترفیس داخلی با آدرس های نا معتبر
  • Core-Router(config-if)#ip nat inside ترجمه آدرس ها بر روی اینترفیس داخلی
  • Core-Router(config)#int fas 0/0 اینترفیس خروجی با آدرس معتبر
  • Core-Router(config-if)#ip nat outside ترجمه آدرس ها روی اینترفیس خروجی

بدین ترتیب هر کلاینت با تنظیم Gateway و DNS سرور امکان دسترسی به اینترنت را خواهد داشت.

خب تا این حد برای راه افتادن دست شما کافیست، حال برای اینکه کانفیگ فعلی روتر را مشاهده کنید از دستور زیر استفاده کنید:

Router#show run

قدم پنجم (ذخیره کنید): به خاطر داشته باشید که تا پیش از ذخیره این تغییرات با قطع شدن برق و یا خاموش روشن کردن روتر، کانفیگ روتر سیسکو از بین خواهد رفت، برای جلوگیری از این مسئله و ذخیره کانفیگ روتر سیسکو از دستور زیر استفاده کنید:

Router#write mem

امیدوارم که تجارب خوب و شیرینی در کانفیگ روتر سیسکو کسب کنید.

منبع: shabake

در صورتی که مطالب سایت برای شما مفید بوده است، می توانید از طریق لینک زیر از سایت حمایت کنید.

image_pdfدانلود نسخه PDF

ارسال یک نظر

آدرس ایمیل شما منتشر نخواهد شد.